Command line tool issue when installed via toolbox

On my system I tried to launch php storm from command line (pstorm) and it doesn't work.


The reason is that /usr/local/bin/pstorm points to 

RUN_PATH = u'/Applications/'
Jetbrains toolbox seems to install apps in:
/Users/USER/Applications/JetBrains Toolbox/APP_NAME
Is there a way w/out editing these files or adding symlinks to get the command line tools to work correctly?

I am having the same issue with rubymine.


[Errno 2] No such file or directory: '/Users/tim/Library/Preferences/RubyMine60/port'
The file /Applications/ does not exist.


This needs to be fixed soon as I use the command line launcher a lot.


I had the same problem, my fix,


Recreate the CLI scripts from within the tool/application.


In PhpStorm-EAP -> Tools -> Create Command Line Launcher..., it prompted me to overwrite my current one, which I allowed, and it started working.



@LI The problem with this seems to be that the CLI launcher needs recreating every time the app is updated, since they live in channel and version scoped directories.

If I `cat $(which webstorm)` I can see things like `RUN_PATH = u'/Volumes/SD/JetBrains/apps/WebStorm/ch-0/173.3942.6/WebStorm 2017.3'`, which is obviously very fragile.


I'm having this same issue, is there an issue on YouTrack? Perhaps an option to have Toolbox update an env var with the path to the idea executable when it updates Intellij?


I would also like to see a fix for this - it is frustrating to have to manually re-create the command line tool after each update. Can there be a setting for this to happen automatically upon installation rather than just manually through the app?


Yes, fix this bug... please...


Doesn't look like it's being addressed though.


yea this is very frustrating, especially when you use multiple tools.


+1 toolbox is useful, but lack of stable cmd line launcher is annoying 


The original post on this is over a year old. It's ridiculous that I can't use a paid tool for something simple like handling core editor, merge and diff duties from the command line because the install path is so fragile. This is something which is easily handled by users, but it's iritating. Setting up commands belongs in the installer.

Until this is fixed, I'm being forced to use VS Code for all my git integration.


To resolve this issue, I deleted the existing command line launcher (/usr/local/bin/pstorm, /usr/local/bin/wstorm, etc.) and toggled the Toolbox setting "Generate shell scripts" off and then back on. It recreated the script. However, it remains to be seen if it will auto-update the script with the next update. Fingers crossed it does, but it isn't the end of the world to delete a file and toggle a checkbox every couple of months ¯\_(ツ)_/¯


Im unchecking and checking "Generate shell scripts" and nothing happens ;/

There is field for "Shell script location" and its empty by default:


Choosing a path for the shell scripts fails with the following error in the logs:

1.14.5179 3631 2019-05-10T09:27:02.168 DEBUG Processes 93 [0510/092702.167511:INFO:CONSOLE(12)] "Fatal error: qrc://index.html/index.js:73:555323 Uncaught TypeError: Cannot read property 'value' of undefined", source: qrc://index.html/index.js (12)
1.14.5179 3631 2019-05-10T09:27:02.168 DEBUG Processes 93
1.14.5179 3631 2019-05-10T09:27:02.188 DEBUG Processes 93 [0510/092702.188208:INFO:CONSOLE(73)] "Uncaught TypeError: Cannot read property 'value' of undefined", source: qrc://index.html/index.js (73)

Wish this was fixed!


Looks like the command line launcher is now called phpstorm on osx. 

cat /usr/local/bin/phpstorm
# Generated by JetBrains Toolbox 1.14.5179 at Mon May 13 22:40:37 2019


When I look at the settings for PhpStorm in Toolbox at the bottom it says "Shell script generation is not enabled", but in the Toolbox settings, script generation is toggled on. Any recommendations? I've tried renaming the original /usr/local/bin/pstorm script thinking it might've been causing issues, but no luck. 



I had same problem and re-launching toolbox worked for me.



@Kodai   Thanks for the advice. I tried the following to no avail.

  • Removed the executable
  • Disabled generate shell scripts
  • Quit toolbox as well as all other jet brains software
  • Launching Toolbox
  • Enabled shell scripts
  • Set the path to `/usr/local/bin`

Once I do this the Toolbox window closes and when I open the Toolbox settings the path in the shell scripts location field is empty again.

I tried different variations of these steps as well. Perhaps my Toolbox install is bad. I can try removing Toolbox and doing a fresh install.

In case this is useful my environment is as follows:

  • macOS 10.14.4
  • Toolbox 1.14.5179
  • PHPStorm 2019.1.2
  • Android Studio 3.4.1

same issue, constantly says script generations is disable3d, and getting the above mentioned error IDES 2019.2 -  Toolbox App 1.15.5666, OS kernel darwin 18.5.0 on x86_64


This is ridiculous.


Hi, I followed steps on the page below and I'm getting the same error: jetbrains-toolbox: command not found


Install the Toolbox App #

  1. Download the tarball .tar.gz from the Toolbox App web page.

  2. Extract the tarball to a directory that supports file execution.

    For example, to extract it to the recommended /opt directory, run the following command:

    sudo tar -xzf jetbrains-toolbox-1.13.4801.tar.gz -C /opt

Execute the jetbrains-toolbox binary from the extracted directory to run the Toolbox App and select which product and version you want to install. After you run the Toolbox App for the first time, it will automatically add the Toolbox App icon to the main menu.


I wonder if the solution is so obvious that the Jet "Brains" don't want to help us or they just don't care.

I wanted to try PyCharm but I guess I will say no, thank you :) 


I fixed this issue by giving my own user write permissions to /usr/local/bin and restarting Toolbox. It might also have worked if I had chosen a different directory that I already had write permissions to.


I won't be using Toolbox until this issue is fixed. The fact that this thread was started in 2017 looks very bad.


Anyone solved it yet?


The issue is that your user needs to be able to write to the directory that you select in the Toolbox app. That there isn't an explanation of this in the Toolbox itself seems quite remiss.


I'm sooooo disappointed that the issue is still not fixed!


M Davey Bsc was spot on. My issue on OSX was that the default location for the scripts is /usr/local/bin which the toolbox doesn't have access to. My work around was to create a new bin folder /Users/myusername/bin, add it to the path variable in shell, and update toolbox to use that.


Hello! We apologise for the inconvenience. We have released a new version of 1.25, the Toolbox App.
In particular, we have improved the shell scripts. The Toolbox App now writes clear messages in the settings about what went wrong. 


Please sign in to leave a comment.