Ubuntu 22.04 - Toolbox - IntelliJ Idea update

Answered

Hello,

First I would like to thank you for your work, IntelliJ Idea is great.

When I check for update in IntelliJ Idea I receive this message :

 IntelliJ IDEA updates are managed by Toolbox App. Launch it to check if updates are available.

I just upgrade my OS to Ubuntu 22.04 and I'm not able to launch Toolbox so no able to update IDE anymore.
I already try some stuff mention here but I was not able to make it work.

I would like to know if you're working on a solution or thinking to allow update Idea from the app and not only from Toolbox ?

Thanks in advance

4
7 comments

On Ubuntu 22.04 LTS unable to run the JetBrains Toolbox.  It simply doesn't launch.  Redownloaded the application and ran the binary and got:  

dlopen(): error loading libfuse.so.2

AppImages require FUSE to run. 
You might still be able to extract the contents of this AppImage 
if you run it with the --appimage-extract option. 
See https://github.com/AppImage/AppImageKit/wiki/FUSE 
for more information

When I follow those instructions and launch the jetbrains-toolbox in the newly created squashfs-root folder there is not output and nothing happens until I Ctrl-C out of it and then there are still no messages (errors or otherwise).

1

Hello,

I had the same issue. The command

sudo apt install libfuse2

solved it for me.

Best regards,
Christian

6

@Christian_Karch ~~It says here https://github.com/AppImage/AppImageKit/wiki/FUSE you should NOT do this on Ubuntu 22.04 or greater. I used snap: `sudo snap install rider --classic` to install rider~~

-1

Uxecw your link just suggest not to install fuse. libfuse2 should be fine. The lib is also suggested in this ticket: https://youtrack.jetbrains.com/issue/TBX-7715/ubuntu2204-install-toolbox-error

1

Christian Karch I guess you are right

0

Parental ticket https://youtrack.jetbrains.com/issue/TBX-7534 
The problem is fixed by installing: sudo apt install libfuse2
We also plan to add this information to the System requirements.

0

In my case, this solution does not work.

denis@labo:/opt$ lsb_release -a
No LSB modules are available.
Distributor ID:    Ubuntu
Description:    Ubuntu 22.04.1 LTS
Release:    22.04
Codename:    jammy

Sorry, it is in French. But is says that the package "libfuse2" is not available anymore.

denis@labo:/opt$ sudo apt-get install -y libfuse2
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture des informations d'état... Fait      
Aucune version du paquet libfuse2 n'est disponible, mais il existe dans la base
de données. Cela signifie en général que le paquet est manquant, qu'il est devenu obsolète
ou qu'il n'est disponible que sur une autre source

E: Le paquet « libfuse2 » n'a pas de version susceptible d'être installée

The only way I found to install the library is by installing it manually from here :

https://packages.ubuntu.com/jammy/amd64/libfuse2/download

denis@labo:~/Téléchargements$ dpkg -c libfuse2_2.9.9-5ubuntu3_amd64.deb
drwxr-xr-x root/root         0 2022-03-23 14:53 ./
drwxr-xr-x root/root         0 2022-03-23 14:53 ./lib/
drwxr-xr-x root/root         0 2022-03-23 14:53 ./lib/x86_64-linux-gnu/
-rw-r--r-- root/root    260376 2022-03-23 14:53 ./lib/x86_64-linux-gnu/libfuse.so.2.9.9
-rw-r--r-- root/root     14400 2022-03-23 14:53 ./lib/x86_64-linux-gnu/libulockmgr.so.1.0.1
drwxr-xr-x root/root         0 2022-03-23 14:53 ./usr/
drwxr-xr-x root/root         0 2022-03-23 14:53 ./usr/share/
drwxr-xr-x root/root         0 2022-03-23 14:53 ./usr/share/doc/
drwxr-xr-x root/root         0 2022-03-23 14:53 ./usr/share/doc/libfuse2/
-rw-r--r-- root/root      2847 2019-01-04 14:33 ./usr/share/doc/libfuse2/NEWS.gz
-rw-r--r-- root/root      1382 2019-01-04 14:33 ./usr/share/doc/libfuse2/README.NFS
-rw-r--r-- root/root      4078 2019-01-04 14:33 ./usr/share/doc/libfuse2/README.md
-rw-r--r-- root/root      1015 2022-03-23 14:53 ./usr/share/doc/libfuse2/changelog.Debian.gz
-rw-r--r-- root/root      2784 2021-08-10 05:54 ./usr/share/doc/libfuse2/copyright
-rw-r--r-- root/root      2381 2019-01-04 14:33 ./usr/share/doc/libfuse2/how-fuse-works
-rw-r--r-- root/root      5111 2019-01-04 14:33 ./usr/share/doc/libfuse2/kernel.txt.gz
lrwxrwxrwx root/root         0 2022-03-23 14:53 ./lib/x86_64-linux-gnu/libfuse.so.2 -> libfuse.so.2.9.9
lrwxrwxrwx root/root         0 2022-03-23 14:53 ./lib/x86_64-linux-gnu/libulockmgr.so.1 -> libulockmgr.so.1.0.1

Then:

denis@labo:~/Téléchargements$ tar xvf data.tar.zst 
./
./lib/
./lib/x86_64-linux-gnu/
./lib/x86_64-linux-gnu/libfuse.so.2.9.9
./lib/x86_64-linux-gnu/libulockmgr.so.1.0.1
./usr/
./usr/share/
./usr/share/doc/
./usr/share/doc/libfuse2/
./usr/share/doc/libfuse2/NEWS.gz
./usr/share/doc/libfuse2/README.NFS
./usr/share/doc/libfuse2/README.md
./usr/share/doc/libfuse2/changelog.Debian.gz
./usr/share/doc/libfuse2/copyright
./usr/share/doc/libfuse2/how-fuse-works
./usr/share/doc/libfuse2/kernel.txt.gz
./lib/x86_64-linux-gnu/libfuse.so.2
./lib/x86_64-linux-gnu/libulockmgr.so.1

Now, you just need to move the library to the right place...

sudo cp ./lib/x86_64-linux-gnu/libfuse.so.2.9.9 /lib/x86_64-linux-gnu/
sudo ldconfig

Then run :

cd
./.local/share/JetBrains/Toolbox/bin/jetbrains-toolbox

It runs!

OK, that's not very clean... but, at least, you've get the toolbox running.

 

0

Please sign in to leave a comment.